Re: [rp-ml] static discharge from beadblasters

From: <>
Date: Fri Jul 17 2009 - 22:38:54 EEST

In a message dated 7/17/2009 11:58:01 A.M. Eastern Daylight Time, writes:


Our company does SLA cleanup with a Trinco dryblast with 170 glass grit
and since we bought this metal box we're getting some fairly severe
shocks. Our attempts at grounding have been unsuccesful. Anyone have any
suggestions. Thanks!

Nicholas Rivers
Nuhill Technologies, Inc.
8600 Xylon Ave N. Ste. 107
Minneapolis, MN 55445

We never had that problem with any of our glass blasting applications at
companies I founded in the past, but it sounds like interference from basic
Make sure there's no coating on the metal surfaces inside the box. If you
have that, you have a big capacitor. Charge can build up on and within
the dielectric. Break away the coating on a lot of interior surfaces to the
bare metal, especially in areas where the beads pile up. The piles can
become charged on the interior like a cloud. Spread them around with the gun.
Make sure ALL of the metal surfaces are grounded. Use a meter to
determine that you have zero ohm connections to all parts of the cabinet. You may
have to add extra ground wires/straps to be certain. Commonly done with
electronics chassis. Ground the gun nozzle if it's metal.
Try another media.
Something here should work.
Ed Grenda
Castle Island Co.
Arlington, MA 02474 USA
_EdGrenda@aol.com_ ( (email)

The Worldwide Guide to Rapid Prototyping

**************Can love help you live longer? Find out now.
Received on Fri Jul 17 22:35:22 2009

This archive was generated by hypermail 2.1.8 : Thu Jan 07 2010 - 08:26:36 EET